• Home
  • Get help
  • Ask a question
Last post 6 hours 58 min ago
Posts last week 247
Average response time last week 17 min
All time posts 56622
All time tickets 8814
All time avg. posts per day 20

Helpdesk is open from Monday through Friday CET

Please create an (free) account to post any question in the support area.
Please check the development versions area. Look at the changelog, maybe your specific problem has been resolved already!
All tickets are private and they cannot be viewed by anyone. We have made public only a few tickets that we found helpful, after removing private information from them.

#8946 – Index.php

Posted in ‘4SEO’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Friday, 05 August 2022 14:54 UTC
helpyougrowmedia

I have always used SH404EF and we would always install, change Htaccess.txt to .Htaccess and then turn it on and it would automatically remove the "en" and the "index.php" and now it doesn't, probably something I have to turn on or off but haven't seen it yet.  Your help is appreciated! 

Friday, 05 August 2022 15:50 UTC
wb_weeblr

Hi

That's because there's basically no relationship between sh404SEF and 4SEO. 4SEO does not do anything to URLs so that it can work together with sh404SEF, with Joomla SEF URL or any other SEF URL extension.

4SEF (currently in beta) is the extension that deals with SEF URLs, and will keep creating the same SEF URLs as sh404SEF.

 change Htaccess.txt to .Htaccess and then turn it on and it would automatically remove the "en" and the "index.php"

That is not a feature of sh404SEF but just of Joomla. You should change htaccess like you always do, and then enable "Use URL rewriting" in Joomla global configuration.

Best regards

Yannick Gaultier

weeblr.com / @weeblr

 

 
Monday, 08 August 2022 12:49 UTC
helpyougrowmedia

Thanks for the reply.   So....  I did that as a test before bothering you and the "en" stays....   https://example.com/

Maybe related to template rather than SEO Program? 

Monday, 08 August 2022 13:04 UTC
wb_weeblr

Hi,

Nothing to do with 4SEO, like I said, it does not do anything to URLs.

I would think you may have enabled by mistake the Joomla Language filter system plugin?

Best regards

Yannick Gaultier

weeblr.com / @weeblr

 

 
Thursday, 08 September 2022 05:34 UTC
system
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.