Hi all,
I created a site with joomla 3.9 and I installed the wbamp_1.12.1.797_community.zip plugin.

When I validate the amp pages in the Structured Data Testing Tool, I get an "A value for the image field is required" error.

But the image is present on the page.
Analyzing the validator code, the following code is not present:

image": {
         "@type": "ImageObject",
         "url": "https://mysite.com/Image.png",
         "width": 800,
         "height": 360
     }


Has any bugs been detected in the plugin?
How to solve?
Thanks

Floyd
Responses (2)
  • Accepted Answer

    Monday, December 17 2018, 02:16 PM - #Permalink
    Hi

    Has any bugs been detected in the plugin?
    This not a bug, all is working as expected. Simply the image on your site is not big enough to be used for structured data on AMP pages.

    Note that:

    - this does not affect your AMP page validation, it only makes your structured data invalid. Google will still see and use your AMP pages normally but without trying to include them in AMP carousel in search results (that's what structured data is used for)

    - here is the page with Google structured data specification. For an image to be valid, it needs to be:

    1200px wide, 800,000 pixels in total, png, jpg or gif format.

    Best regards
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 17 2018, 03:56 PM - #Permalink
    Hi all staff,

    thanks for your reply.

    I changed the image size and now even the structured data in the AMP pages are validated.

    Thanks

    Floyd
    The reply is currently minimized Show
Your Reply